龙都娱乐»PHP»2008年我买了一本书 书名叫“PHP 6”

2008年我买了一本书 书名叫“PHP 6”

来源:vaikan 发布时间:2014-09-03 阅读次数:
  上个星期天,我感觉应该整理一下我的书柜。于是,在书柜里,我发现了一本几乎完全忘记的书(我想不起来为什么要买它!):《PHP 6 – 快速简洁的Web开发》   这本书出版于2008年一月。而六年之后的今天,PHP的最新版本仍然是5.5 5.6(在我写这篇博客的时候,PHP 5.6发布了,但事实上,这使得PHP 6的诞生更遥不可及)。很显然,这本书的作者是个市场宣传高手(很多人,那些不太清楚PHP的发展的人,今天仍在会去买这本书,以为这是刚刚出版的书),这似乎也正好反映了一些PHP的发展情况。   根据维基百科上的信息,PHP 5.0发布于2005年。估计PHP 6版本中会在PHP 5的基础上新增一些非常有用的特性,特别是关于对Unicode的支持。但事实上事情并没有像预测的这样发展,很多PHP 6设计中的特性后来都被放到了PHP 5中。9年之后,我们仍然只能使用PHP 5。没错,看起来最近PHP的开发正在加速,传说中的PHPNG(PHP Next Generation)将会在性能上带来大幅度提高(还有很多其它语法上的改进),它将会做为PHP 7的基础(他们越过了PHP 6,避免与之前的设计路线混淆,比如,我的这本书里讲到的知识),还有另外一些改进,比如HHVM (PHP即时编译)。   鉴于PHP语言的重要影响(你要知道,WordPress——整个互联网中23%的网站使用的博客系统——是用PHP写的。),我相信,PHP一定会继续向前发展。我对PHP社区并不太了解,不清楚为什么PHP的发展会这么迟缓,但从很多的主机供应商来看,它们为了避免兼容性问题,更喜欢使用老版本的PHP(甚至是那些已经或即将不被支持的版本)。 php6   这样一来,一些流行的软件,例如WordPress,无法再提高它们的最低支持版本(目前的最低要求是PHP 5.2.4),这就变成了一个鸡和蛋的问题。结果,有超过2千万的用户在他们的网站上仍然使用过期的、含有潜在安全危险的老PHP版本。如果你有时间,可以看看关于这个问题的Twitter讨论(注意讨论的日期),相信能让你更了解其中复杂的形势。
我们打算在今年3月份停止对PHP进行维护支持。可同时,65%的WordPress网站仍然使用的是PHP 5.2。真不愿看到这样的情况,但没有办法。 — Andrew Nacin (@nacin) December 20, 2012
PHP的不幸现状:我两年前的猜想并没有如愿,PHP 5.2仍然占有39%的份额,而且下降的速度缓慢。 https://t.co/c4ffOZyx7D — Andrew Nacin (@nacin) August 6, 2014
  英文原文:In 2008, I bought a book titled “PHP 6″. Six years later, PHP version is still 5.5
QQ群: WEB龙都娱乐官方总群(83010142) 加群密码:关注下方微信公众号,发送消息 mm 获取
提示:更多精彩内容关注微信公众号:全栈龙都娱乐中心(fsder-com)
PHP
网友评论(共2条评论) 正在载入评论......
理智评论文明上网,拒绝恶意谩骂 发表评论 / 共2条评论
登录会员中心
龙都娱乐